aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <colm.donelan@arm.com>2023-03-06 12:34:54 +0000
committerColm Donelan <colm.donelan@arm.com>2023-03-06 22:06:38 +0000
commitd047262b7fb68ad1fe0a2273ee79ab7952c72a6e (patch)
tree5e35dd8938cea094218fd84abb14d6418711df7d /CMakeLists.txt
parent0e5a1317156f97c56baf556ddc8a638228dbec74 (diff)
downloadarmnn-d047262b7fb68ad1fe0a2273ee79ab7952c72a6e.tar.gz
Fixing compare output feature in ExecuteNetwork
The -A -B -C options in execute network were attempting to calculate the RMS error over output tensors. However, the calculation was mixing tensor elements and bytes when doing the calculation. This patch changes the calculation to use a per byte RMS error calculation. Signed-off-by: Colm Donelan <colm.donelan@arm.com> Change-Id: If30230a16cfed1a8804b4d54ed1abcd371f26664
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9eab90afef..3b788cd056 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -835,6 +835,12 @@ if(BUILD_UNIT_TESTS)
)
endif()
+ if(BUILD_TESTS)
+ list(APPEND unittest_sources
+ ./tests/NetworkExecutionUtils/NetworkExecutionUtils.cpp
+ ./tests/NetworkExecutionUtils/test/NetworkExecutionUtilsTests.cpp)
+ endif()
+
foreach(lib ${armnnUnitTestLibraries})
message(STATUS "Adding object library dependency to UnitTests: ${lib}")
list(APPEND unittest_sources $<TARGET_OBJECTS:${lib}>)