aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTracy Narine <tracy.narine@arm.com>2024-02-26 15:05:11 +0000
committerTracy Narine <tracy.narine@arm.com>2024-02-28 14:17:52 +0000
commit2883a86c5a167aea3c736529bff5921ab6cbc99c (patch)
treed9e000d96246c622d82e185af186a0bf64b2896c /CMakeLists.txt
parentc24577b21f4e8f4a1253632e31dea5d39a17ca26 (diff)
downloadarmnn-2883a86c5a167aea3c736529bff5921ab6cbc99c.tar.gz
IVGCVSW-8172 Add macOS support to build tool setup
* Updates build rules for platform * Failing unit tests excluded (dynamic backends, profiling) * install-packages.sh generates manual setup information Signed-off-by: Tracy Narine <tracy.narine@arm.com> Change-Id: I2d3d434aa615a8796c0cb94cd5b9c35a5acfd148
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29a72e36eb..e8067350ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright © 2017-2023 Arm Ltd and Contributors. All rights reserved.
+# Copyright © 2017-2024 Arm Ltd and Contributors. All rights reserved.
# Copyright © 2020 NXP
# SPDX-License-Identifier: MIT
#
@@ -476,10 +476,12 @@ endif()
target_compile_definitions(armnn PRIVATE "ARMNN_COMPILING_DLL")
-# Generate a map file for all build modes
-set_property(TARGET armnn APPEND_STRING PROPERTY
- LINK_FLAGS " -Wl,-Map=libarmnnMapFile.map")
-message(STATUS "Linker will generate mapfile ")
+# Generate a map file for Linux build modes
+if (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Darwin))
+ set_property(TARGET armnn APPEND_STRING PROPERTY
+ LINK_FLAGS " -Wl,-Map=libarmnnMapFile.map")
+ message(STATUS "Linker will generate mapfile ")
+endif()
target_include_directories(armnn
PUBLIC