aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29a72e36eb..e8067350ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright © 2017-2023 Arm Ltd and Contributors. All rights reserved.
+# Copyright © 2017-2024 Arm Ltd and Contributors. All rights reserved.
# Copyright © 2020 NXP
# SPDX-License-Identifier: MIT
#
@@ -476,10 +476,12 @@ endif()
target_compile_definitions(armnn PRIVATE "ARMNN_COMPILING_DLL")
-# Generate a map file for all build modes
-set_property(TARGET armnn APPEND_STRING PROPERTY
- LINK_FLAGS " -Wl,-Map=libarmnnMapFile.map")
-message(STATUS "Linker will generate mapfile ")
+# Generate a map file for Linux build modes
+if (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Darwin))
+ set_property(TARGET armnn APPEND_STRING PROPERTY
+ LINK_FLAGS " -Wl,-Map=libarmnnMapFile.map")
+ message(STATUS "Linker will generate mapfile ")
+endif()
target_include_directories(armnn
PUBLIC