aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorViet-Hoa Do <viet-hoa.do@arm.com>2023-05-30 09:34:32 +0100
committerViet-Hoa Do <viet-hoa.do@arm.com>2023-06-27 09:42:51 +0000
commitbd4f6b9ed37ed7a222e36ce6823ba96396f60deb (patch)
treed1117a182d2d5fe8d2cef1ed631e3723b2aca354 /compute_kernel_writer/CMakeLists.txt
parent8c49f16e5909a9bd5dc6e68638d2e2d8acc2fc66 (diff)
downloadComputeLibrary-bd4f6b9ed37ed7a222e36ce6823ba96396f60deb.tar.gz
Compute kernel writer API and prototype
* Add the public API for compute kernel writer. * Use the prototype as the implementation of the public API. Resolves: COMPMID-5790 Signed-off-by: Viet-Hoa Do <viet-hoa.do@arm.com> Change-Id: I9d80e15325e1d953feb87c1f2eb61a587bb9ab5e Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9814 Reviewed-by: Jakub Sujak <jakub.sujak@arm.com> Tested-by: Arm Jenkins <bsgcomp@arm.com> Comments-Addressed: Arm Jenkins <bsgcomp@arm.com> Benchmark: Arm Jenkins <bsgcomp@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt28
1 files changed, 27 insertions, 1 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index 93372de3db..4bf8494484 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -50,6 +50,7 @@ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -Os")
option(CKW_ENABLE_OPENCL "Enable OpenCL code generation" OFF)
option(CKW_ENABLE_ASSERTS "Enable assertions. Always enabled in Debug builds" OFF)
option(CKW_BUILD_TESTING "Build the Compute Kernel Writer validation test suite" OFF)
+option(CKW_BUILD_EXAMPLES "Build the Compute Kernel Writer examples" OFF)
option(CKW_CCACHE "Enable compiler cache builds" OFF)
#---------------------------------------------------------------------
@@ -104,7 +105,19 @@ target_sources(ckw PRIVATE
src/TensorInfo.cpp
src/TensorUtils.cpp
src/TileInfo.cpp
- )
+
+ src/Kernel.cpp
+ src/KernelWriter.cpp
+ src/OperandBase.cpp
+ src/TileOperand.cpp
+ src/TensorOperand.cpp
+ src/TensorTileSampler.cpp
+
+ src/acl/AclKernelWriter.cpp
+ src/acl/AclScopedKernelWriter.cpp
+ src/acl/AclComponentArgument.cpp
+)
+
if(CKW_ENABLE_OPENCL)
target_sources(ckw PRIVATE
src/cl/CLConstantTile.cpp
@@ -143,6 +156,19 @@ if(CKW_BUILD_TESTING)
endif()
#---------------------------------------------------------------------
+# Example
+
+if(CKW_BUILD_EXAMPLES)
+ add_executable(ckw_example_add_exp_store
+ examples/add_exp_store.cpp
+ )
+
+ target_link_libraries(ckw_example_add_exp_store
+ PUBLIC ckw
+ )
+endif()
+
+#---------------------------------------------------------------------
# Installing
install(TARGETS ckw