aboutsummaryrefslogtreecommitdiff
path: root/compute_kernel_writer/CMakeLists.txt
diff options
context:
space:
mode:
authorGian Marco Iodice <gianmarco.iodice@arm.com>2023-06-15 17:40:28 +0100
committerGian Marco Iodice <gianmarco.iodice@arm.com>2023-06-20 14:03:01 +0000
commit68e9c4dfd3c02b3f2e25290f9ad9c3b0bc001d25 (patch)
treea846a18407fb47c9e56c3f617dc4f02793aa413e /compute_kernel_writer/CMakeLists.txt
parent59b9ff0adac8b7d7044b4a74c23b710fe1062d10 (diff)
downloadComputeLibrary-68e9c4dfd3c02b3f2e25290f9ad9c3b0bc001d25.tar.gz
Implement CLConstantTile
- Create tile object to store constant variables - Add unit tests for the CLConstantTile - Extend unit test for CLTile Resolves COMPMID-5786 Signed-off-by: Gian Marco Iodice <gianmarco.iodice@arm.com> Change-Id: I351d8b88327e071791b781a04a6ab4990c89c04d Reviewed-on: https://review.mlplatform.org/c/ml/ComputeLibrary/+/9794 Benchmark: Arm Jenkins <bsgcomp@arm.com> Tested-by: Arm Jenkins <bsgcomp@arm.com> Reviewed-by: Viet-Hoa Do <viet-hoa.do@arm.com>
Diffstat (limited to 'compute_kernel_writer/CMakeLists.txt')
-rw-r--r--compute_kernel_writer/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/compute_kernel_writer/CMakeLists.txt b/compute_kernel_writer/CMakeLists.txt
index 4338f7bbb4..f203a18f56 100644
--- a/compute_kernel_writer/CMakeLists.txt
+++ b/compute_kernel_writer/CMakeLists.txt
@@ -107,8 +107,10 @@ target_sources(ckw PRIVATE
)
if(CKW_ENABLE_OPENCL)
target_sources(ckw PRIVATE
+ src/cl/CLConstantTile.cpp
src/cl/CLHelpers.cpp
src/cl/CLTile.cpp
+ src/cl/ICLTile.cpp
)
endif()
@@ -135,7 +137,9 @@ if(CKW_BUILD_TESTING)
validation/Validation.cpp
)
if(CKW_ENABLE_OPENCL)
- target_sources(ckw_validation PRIVATE validation/tests/CLTileTest.hpp)
+ target_sources(ckw_validation PRIVATE
+ validation/tests/CLConstantTileTest.hpp
+ validation/tests/CLTileTest.hpp)
endif()
target_link_libraries(ckw_validation PRIVATE ckw)