aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJosef Malmström <josef.malmstrom@arm.com>2023-09-20 16:00:11 +0000
committerEric Kunze <eric.kunze@arm.com>2023-09-28 18:25:54 +0000
commit41ebe72588b20b912eb8c9e082b2d66b37564ad3 (patch)
tree3966b8be7418063cd8c55ce84530bb6b8661c183 /pyproject.toml
parentc8fdccfa51a631a4d6df725a88d38d4679b2a439 (diff)
downloadreference_model-41ebe72588b20b912eb8c9e082b2d66b37564ad3.tar.gz
Change version scheme to not guess next version
By default, setuptools_scm will guess the next version and supply that as the version number when the package is installed. For example, this meant that installing when tag "v0.60.2" was checked out would give package version "0.60.3.dev8+gf5a8283.d20230920". With this change, the package version would instead be "0.60.2.post1.dev8+gad80c03". Change-Id: I0bca9a6abec38e82839b52fe2933d2c0d14b5a84 Signed-off-by: Josef Malmström <josef.malmstrom@arm.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 49aa0ed..4a58d8c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,4 +1,4 @@
-# Copyright (c) 2021-2022 Arm Limited.
+# Copyright (c) 2021-2023 Arm Limited.
# SPDX-License-Identifier: Apache-2.0
[build-system]
@@ -10,3 +10,4 @@ requires = [
build-backend = "setuptools.build_meta"
[tool.setuptools_scm]
+version_scheme = "no-guess-dev"