aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFredrik Svedberg <fredrik.svedberg@arm.com>2021-05-11 13:51:47 +0200
committerMauricio Briceno <mauricio.briceno@arm.com>2021-05-13 18:01:21 +0200
commit93d5c35feaae8f2fe8e0361ffc19e31d463ca099 (patch)
treec5179f8e06c5aa3e16513849f4be338393661afb /setup.py
parent67e11f7bce40d72e0dda97cf658a3c3ee600c1eb (diff)
downloadethos-u-vela-93d5c35feaae8f2fe8e0361ffc19e31d463ca099.tar.gz
Fix mlw_module
Fixedx size calculation in mlw_reorder_encode. Fixed build warnings. Signed-off-by: Fredrik Svedberg <fredrik.svedberg@arm.com> Change-Id: Iac9408b9972a29b5a3403ba11f80dc4eaaa35453
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d2137437..6900a67d 100644
--- a/setup.py
+++ b/setup.py
@@ -44,6 +44,7 @@ mlw_module = Extension(
"ethosu.mlw_codec",
["ethosu/mlw_codec/mlw_encode.c", "ethosu/mlw_codec/mlw_decode.c", "ethosu/mlw_codec/mlw_codecmodule.c"],
include_dirs=[np.get_include()],
+ define_macros=[("NPY_NO_DEPRECATED_API", "NPY_1_9_API_VERSION")],
)
setup(