aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMauricio Briceno <mauricio.briceno@arm.com>2021-05-05 12:47:28 +0200
committerpatrik.gustavsson <patrik.gustavsson@arm.com>2021-05-07 13:16:11 +0000
commit67e11f7bce40d72e0dda97cf658a3c3ee600c1eb (patch)
treeb9b281a07b352fde25161002034770cfde39f115 /setup.py
parentc875aa6fdd8740f759305ff0fec9917977d019f0 (diff)
downloadethos-u-vela-67e11f7bce40d72e0dda97cf658a3c3ee600c1eb.tar.gz
weight_compressor: added mlw_reorder_encode3.0.0.rc1
- Moves reordering to C - Runtime is greatly minimized for encoding weights Change-Id: Ifff01e7b1ea6d5cec68310a155c3b80aa1a38545 Signed-off-by: Mauricio Briceno <mauricio.briceno@arm.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8cf61951..d2137437 100644
--- a/setup.py
+++ b/setup.py
@@ -18,6 +18,7 @@
import os
import re
+import numpy as np
from setuptools import Extension
from setuptools import find_namespace_packages
from setuptools import setup
@@ -42,6 +43,7 @@ with open(os.path.join(this_directory, "README.md"), encoding="utf-8") as f:
mlw_module = Extension(
"ethosu.mlw_codec",
["ethosu/mlw_codec/mlw_encode.c", "ethosu/mlw_codec/mlw_decode.c", "ethosu/mlw_codec/mlw_codecmodule.c"],
+ include_dirs=[np.get_include()],
)
setup(