aboutsummaryrefslogtreecommitdiff
path: root/driver_library/CMakeLists.txt
diff options
context:
space:
mode:
authorDavide Grohmann <davide.grohmann@arm.com>2022-04-07 14:50:50 +0200
committerDavide Grohmann <davide.grohmann@arm.com>2022-04-12 12:52:23 +0200
commit80f8ddf050d594ec663b01cb800e9547c9f919d0 (patch)
tree8952b03560639a89a0780335e28abc0ccc83c8be /driver_library/CMakeLists.txt
parent442fefb74a28307cfcd009723504ea5ac1353430 (diff)
downloadethos-u-linux-driver-stack-80f8ddf050d594ec663b01cb800e9547c9f919d0.tar.gz
Drop tflite and flatbuffer dependencies
There is not real need for the linux_driver_stack to know about tflite and flatbuffers. A better approach is to just pass the buffer to the firmware to be processes, i.e., either parsed or executed. This solves issues when linux_driver_stack and firmware are not in sync with the same library versions. Change-Id: I9b2a12e69f37f61b1ac594433a15883fb1c67b9c
Diffstat (limited to 'driver_library/CMakeLists.txt')
-rw-r--r--driver_library/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/driver_library/CMakeLists.txt b/driver_library/CMakeLists.txt
index 41eb115..375192f 100644
--- a/driver_library/CMakeLists.txt
+++ b/driver_library/CMakeLists.txt
@@ -24,14 +24,13 @@ project("driver_library" VERSION 1.0.0 LANGUAGES C CXX)
# Build the driver library
add_library(ethosu STATIC "src/ethosu.cpp")
-# Add public include directory and select which files to install
+# Add public include directory and select which files to install
target_include_directories(ethosu PUBLIC "include")
set_target_properties(ethosu PROPERTIES PUBLIC_HEADER "include/ethosu.hpp")
set_target_properties(ethosu PROPERTIES VERSION ${PROJECT_VERSION})
-target_link_libraries(ethosu PRIVATE flatbuffers)
# Install library and public headers
install(TARGETS ethosu
LIBRARY DESTINATION "lib"
ARCHIVE DESTINATION "lib"
- PUBLIC_HEADER DESTINATION "include") \ No newline at end of file
+ PUBLIC_HEADER DESTINATION "include")