aboutsummaryrefslogtreecommitdiff
path: root/applications/freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'applications/freertos/CMakeLists.txt')
-rw-r--r--applications/freertos/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/applications/freertos/CMakeLists.txt b/applications/freertos/CMakeLists.txt
index 292f598..8be3b3a 100644
--- a/applications/freertos/CMakeLists.txt
+++ b/applications/freertos/CMakeLists.txt
@@ -16,8 +16,8 @@
# limitations under the License.
#
-# Exclude this app if freertos target does not exist
-if (NOT TARGET freertos_kernel)
+# Exclude this app if freertos target does not exist or if NPU configuration is not H128
+if (NOT TARGET freertos_kernel OR NOT ETHOSU_TARGET_NPU_CONFIG STREQUAL "ethos-u55-128")
message("Skipping FreeRTOS application")
return()
endif()