aboutsummaryrefslogtreecommitdiff
path: root/applications/freertos/CMakeLists.txt
diff options
context:
space:
mode:
authorLior Dekel <Lior.dekel@arm.com>2021-10-04 19:15:24 +0300
committerLior Dekel <Lior.dekel@arm.com>2021-10-06 15:43:24 +0300
commit52fddd00d0eb547d41074046c9f587a3a0679298 (patch)
tree66fc835afef7d9c50e3bc38f8d93160e4139142c /applications/freertos/CMakeLists.txt
parent3e128627b8f604f47c8cc55cbb9d43c204f8e50f (diff)
downloadethos-u-core-platform-52fddd00d0eb547d41074046c9f587a3a0679298.tar.gz
NPU configuration support update in relevant apps.
Bare metal app - added all the configurations for the different NPUs. FreeRTOS app and driver_unit_conv test - excluded all NPU configurations except ethos-u55-128. Change-Id: I6f69526613cd18c572af1186e5997816fad246b4
Diffstat (limited to 'applications/freertos/CMakeLists.txt')
-rw-r--r--applications/freertos/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/applications/freertos/CMakeLists.txt b/applications/freertos/CMakeLists.txt
index 292f598..8be3b3a 100644
--- a/applications/freertos/CMakeLists.txt
+++ b/applications/freertos/CMakeLists.txt
@@ -16,8 +16,8 @@
# limitations under the License.
#
-# Exclude this app if freertos target does not exist
-if (NOT TARGET freertos_kernel)
+# Exclude this app if freertos target does not exist or if NPU configuration is not H128
+if (NOT TARGET freertos_kernel OR NOT ETHOSU_TARGET_NPU_CONFIG STREQUAL "ethos-u55-128")
message("Skipping FreeRTOS application")
return()
endif()