aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2019-06-18 12:30:37 +0100
committerFrancis Murtagh <francis.murtagh@arm.com>2019-06-19 10:38:22 +0000
commitbee4bc944aa50782ff22cb4a31fbc611212a5e89 (patch)
tree94fe0195732c6bb3110f7920965e1656daddc9dd /tests/CMakeLists.txt
parent0c64f461e071f281dab14d6b9dde85a0235d0c25 (diff)
downloadarmnn-bee4bc944aa50782ff22cb4a31fbc611212a5e89.tar.gz
IVGCVSW-3299 Add Uint8 Support to Model Accuracy Checker
* Seperate ExecuteNetwork main function into standalone application * Include NetworkExecutionUtils header and remove duplicate functions * Add uint8 and int32 support to ModelAccuracyChecker Change-Id: I5fb4bc147232f8388f37eea7db5130b04fd215d1 Signed-off-by: Francis Murtagh <francis.murtagh@arm.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index dfcf4b48e0..19612543b6 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -294,6 +294,21 @@ endif()
if(BUILD_ACCURACY_TOOL)
macro(AccuracyTool executorName)
target_link_libraries(${executorName} ${CMAKE_THREAD_LIBS_INIT})
+ if (BUILD_ARMNN_SERIALIZER)
+ target_link_libraries(${executorName} armnnSerializer)
+ endif()
+ if (BUILD_CAFFE_PARSER)
+ target_link_libraries(${executorName} armnnCaffeParser)
+ endif()
+ if (BUILD_TF_PARSER)
+ target_link_libraries(${executorName} armnnTfParser)
+ endif()
+ if (BUILD_TF_LITE_PARSER)
+ target_link_libraries(${executorName} armnnTfLiteParser)
+ endif()
+ if (BUILD_ONNX_PARSER)
+ target_link_libraries(${executorName} armnnOnnxParser)
+ endif()
if(OPENCL_LIBRARIES)
target_link_libraries(${executorName} ${OPENCL_LIBRARIES})
endif()