aboutsummaryrefslogtreecommitdiff
path: root/python/pyarmnn/setup.py
diff options
context:
space:
mode:
authorNikhil Raj <nikhil.raj@arm.com>2021-04-30 15:44:24 +0100
committerNikhil Raj <nikhil.raj@arm.com>2021-06-01 22:14:24 +0100
commit7dcc6971722fe3780ca81c51695905e864a6637d (patch)
tree113696974bcbd3a0a4e6df73ea0470c47eca1294 /python/pyarmnn/setup.py
parentb8942bf1a49b8ec710fafd7915dd9c8fee62230d (diff)
downloadarmnn-7dcc6971722fe3780ca81c51695905e864a6637d.tar.gz
IVGCVSW-5833 Move the ProfilingGuid out of Types.hpp to its own header in profiling common
!android-nn-driver:5691 Signed-off-by: Nikhil Raj <nikhil.raj@arm.com> Change-Id: Ib71af0831e324ac6bd27b1a36f4a6ec1a703b14a
Diffstat (limited to 'python/pyarmnn/setup.py')
-rwxr-xr-xpython/pyarmnn/setup.py25
1 files changed, 19 insertions, 6 deletions
diff --git a/python/pyarmnn/setup.py b/python/pyarmnn/setup.py
index 78868549f3..7bc4a47619 100755
--- a/python/pyarmnn/setup.py
+++ b/python/pyarmnn/setup.py
@@ -124,12 +124,25 @@ def find_includes(armnn_include_env: str = INCLUDE_ENV_NAME):
Returns:
list: A list of paths to include.
"""
- armnn_include_path = os.getenv(armnn_include_env)
- if armnn_include_path is not None and os.path.exists(armnn_include_path):
- armnn_include_path = [armnn_include_path]
- else:
- armnn_include_path = ['/usr/local/include', '/usr/include']
- return armnn_include_path
+
+ # split multiple paths
+ global armnn_include_path
+ armnn_include_path_raw = os.getenv(armnn_include_env)
+ if not armnn_include_path_raw == None:
+ armnn_include_path = armnn_include_path_raw.split(",")
+
+ # validate input paths
+ armnn_include_path_result = []
+ for path in armnn_include_path:
+ if path is not None and os.path.exists(path):
+ armnn_include_path_result = armnn_include_path_result + [path]
+
+
+ # if none exist revert to default
+ if len(armnn_include_path_result) == 0:
+ armnn_include_path_result = ['/usr/local/include', '/usr/include']
+ return armnn_include_path_result
+
@lru_cache(maxsize=1)