aboutsummaryrefslogtreecommitdiff
path: root/python/pyarmnn/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan OShea <ryan.oshea3@arm.com>2023-08-01 17:15:24 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2023-08-03 21:52:34 +0000
commit7d1b1ca5b25a3aaeecebc537e8cbed2ee1ed3337 (patch)
treea4ae0db77581214c2d01740496b6d1a77b926aae /python/pyarmnn/CMakeLists.txt
parent0f3e9a09a90664fc7c6479f1d7b312a4671d9659 (diff)
downloadarmnn-7d1b1ca5b25a3aaeecebc537e8cbed2ee1ed3337.tar.gz
IVGCVSW-7952 Output deprecation message when building pyarmnn
* Adds warning message when enabling pyarmnn through CMake * Adds print out when building pyarmnn through setup.py * Remove deprecated functions from batch matmul descripter Signed-off-by: Ryan OShea <ryan.oshea3@arm.com> Change-Id: I210ddbd0dd2f3b0d260a644bc62b8754375fbebe
Diffstat (limited to 'python/pyarmnn/CMakeLists.txt')
-rw-r--r--python/pyarmnn/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/pyarmnn/CMakeLists.txt b/python/pyarmnn/CMakeLists.txt
index e2375c468d..0a4cf1b09e 100644
--- a/python/pyarmnn/CMakeLists.txt
+++ b/python/pyarmnn/CMakeLists.txt
@@ -1,5 +1,6 @@
#
# Copyright 2020 NXP
+# Copyright © 2023 Arm Ltd. All rights reserved.
# SPDX-License-Identifier: MIT
#
set(SETUP_PY_IN "${CMAKE_CURRENT_SOURCE_DIR}/setup.py")
@@ -8,6 +9,8 @@ set(SWIG_GENERATE_IN "${CMAKE_CURRENT_SOURCE_DIR}/swig_generate.py")
set(SWIG_GENERATE "${CMAKE_CURRENT_BINARY_DIR}/swig_generate.py")
set(OUT_WRAP "${CMAKE_CURRENT_BINARY_DIR}/pyarmnn.wrap.timestamp")
+message(WARNING "PyArmNN is deprecated. To use ArmNN on python, please use the tflite delegate. Expected to be removed in release 24.05.")
+
configure_file(${SETUP_PY_IN} ${SETUP_PY} COPYONLY)
configure_file(${SWIG_GENERATE_IN} ${SWIG_GENERATE} COPYONLY)