aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorTeresa Charlin <teresa.charlinreyes@arm.com>2023-04-27 14:42:23 +0100
committerTeresa Charlin <teresa.charlinreyes@arm.com>2023-04-27 15:24:11 +0100
commitf69ae5602f370b8f108618a8f01e39a9538d3651 (patch)
tree803e756259b8ad277fdcded79f381806994492ac /delegate/CMakeLists.txt
parent0cc93ab9e7cee6a0fc43f73c3520d3579464ce72 (diff)
downloadarmnn-f69ae5602f370b8f108618a8f01e39a9538d3651.tar.gz
IVGCVSW-7589 IVGCVSW-7595 IVGCVSW-7593 ElementwiseUnary, Normalization and LogicalBinary operators for opaque delegate
* Report the operator as part of the layer name for: - LogicalBinary, - ElementwiseUnary - Comparison - Activation * Fixing indentation in Gather.hpp * Removing not needed includes in Gather, GatherNd and Comparison * Correct end of namespace comment in Comparison * Correct log from TfLiteArmnnDelegate to TfLiteArmnnOpaqueDelegate Signed-off-by: Teresa Charlin <teresa.charlinreyes@arm.com> Change-Id: Ia0d497709309e912d31eb4b6db0fef9e79b7a3af
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 3914a24fb5..f46119cf3a 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -274,12 +274,18 @@ if(BUILD_UNIT_TESTS)
test/Convolution2dTest.cpp
test/ConvolutionTestHelper.hpp
test/DepthwiseConvolution2dTest.cpp
+ test/ElementwiseUnaryTestHelper.hpp
+ test/ElementwiseUnaryTest.cpp
test/FullyConnectedTest.cpp
test/FullyConnectedTestHelper.hpp
test/GatherTest.cpp
test/GatherTestHelper.hpp
test/GatherNdTest.cpp
test/GatherNdTestHelper.hpp
+ test/LogicalTest.cpp
+ test/LogicalTestHelper.hpp
+ test/NormalizationTest.cpp
+ test/NormalizationTestHelper.hpp
test/PreluTest.cpp
test/PreluTestHelper.hpp
test/TestUtils.hpp