aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Kelly <mike.kelly@arm.com>2022-05-20 17:18:59 +0100
committerMike Kelly <mike.kelly@arm.com>2022-05-26 16:19:09 +0100
commitf74937eca3eece3ccd439933306ac0f32415390e (patch)
tree39cc39c78f77f2b10c90ae8d583d9952175e57dc /CMakeLists.txt
parent5ee069ef6c4e7002ddc19ade8a1fbca7ba027d68 (diff)
downloadarmnn-f74937eca3eece3ccd439933306ac0f32415390e.tar.gz
GitHub #644 fails to build with flatbuffers 2.0.6
* Removed the pre-generated ArmnnSchema_generated.h * This version was generated using flatbuffers v1.12.0 and it contains code that's incompatible with newer versions * Android.mk will look for ArmnnSchema_generated.h in the armnnGenerated directory in the armnn directory. * The Serializer and Deserializer will look for ArmnnSchema_generated.h in the armnnGenerated directory. !android-nn-driver:7626 Signed-off-by: Mike Kelly <mike.kelly@arm.com> Change-Id: I13ff6b6c78740cf1f82750f56caab83200e6a3e5 Signed-off-by: Mike Kelly <mike.kelly@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52e60e00d4..208bbf00e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -835,6 +835,7 @@ if(BUILD_UNIT_TESTS)
endif()
if(BUILD_ARMNN_SERIALIZER AND ARMNNREF)
+ target_include_directories(UnitTests SYSTEM PRIVATE generated)
target_include_directories(UnitTests SYSTEM PRIVATE ${CMAKE_CURRENT_BINARY_DIR}/src/armnnSerializer)
target_include_directories(UnitTests SYSTEM PRIVATE "${FLATBUFFERS_INCLUDE_PATH}")
target_link_libraries(UnitTests armnnSerializer)