aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2022-10-10 12:42:16 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2022-10-27 12:03:21 +0100
commitd646b5504351ab3c3ab8152553465c8e36947e5b (patch)
treed67eb1a4f18b9cff1c5e5ff067ba4c4b92bff561 /CMakeLists.txt
parent6a76e562019ef492a39d21de6850534d0a561782 (diff)
downloadarmnn-d646b5504351ab3c3ab8152553465c8e36947e5b.tar.gz
IVGCVSW-7273 Integrate TOSA Reference Model into Arm NN
Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ie9aa1aa20a5bc837e005a7a36d4d07b4cd8d021b
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96f94be84a..ff05fb3f5a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -541,6 +541,17 @@ if (ARMNNTOSAREF)
target_link_libraries(armnn PUBLIC -Wl,--whole-archive ${TOSA_SERIALIZATION_LIB} -Wl,--no-whole-archive)
endif()
+
+ if (TOSA_REFERENCE_MODEL_LIB)
+ target_link_libraries(armnn PUBLIC -Wl,--whole-archive ${TOSA_REFERENCE_MODEL_LIB} -Wl,--no-whole-archive)
+ else()
+ find_library(TOSA_REFERENCE_MODEL_LIB
+ NAMES libtosa_reference_model_lib.a tosa_reference_model_lib
+ HINTS ${TOSA_REFERENCE_MODEL_ROOT}/lib /usr/local/lib /usr/lib)
+ message(STATUS "TOSA Reference Model set to ${TOSA_REFERENCE_MODEL_LIB}")
+
+ target_link_libraries(armnn PUBLIC -Wl,--whole-archive ${TOSA_REFERENCE_MODEL_LIB} -Wl,--no-whole-archive)
+ endif()
endif()
if(PROFILING_BACKEND_STREAMLINE AND (NOT ("${CMAKE_SYSTEM_NAME}" STREQUAL Android)))