aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <Colm.Donelan@arm.com>2019-09-09 11:59:08 +0100
committerMatteo Martincigh <matteo.martincigh@arm.com>2019-09-09 16:24:39 +0000
commita85e215dd1b027c5ef88621d1b4d5f6e078605da (patch)
tree2c5b1046788ad231daaecdedad08519ee8ae1a39 /CMakeLists.txt
parent8fccd86b95be418d1b0397bfd5f48a319f210180 (diff)
downloadarmnn-a85e215dd1b027c5ef88621d1b4d5f6e078605da.tar.gz
IVGCVSW-3720 Start a UDS server that accepts connections.
* Add a CLI paramter to the Gatord mock client to specify a namespace. * Open a listening socket on that namespace. * Wait for one connection on the socket. Signed-off-by: Colm Donelan <Colm.Donelan@arm.com> Change-Id: Ic85b4defd5ad2010bb255472c030a91a23cec1d9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b29a709643..217c420d4a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -825,6 +825,8 @@ if(BUILD_GATORD_MOCK)
tests/profiling/GatordMockMain.cpp
tests/profiling/CommandLineProcessor.hpp
tests/profiling/CommandLineProcessor.cpp
+ tests/profiling/GatordMockService.hpp
+ tests/profiling/GatordMockService.cpp
)
include_directories( ${Boost_INCLUDE_DIRS} )