aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorColm Donelan <colm.donelan@arm.com>2024-04-23 14:19:22 +0100
committerColm Donelan <colm.donelan@arm.com>2024-04-23 14:19:22 +0100
commit22107e251af9d0b589ea8c47c53c2a6095333272 (patch)
treedfa3e7401682cde657c737817969f03bef163f39 /CMakeLists.txt
parent693acb46c5829f32082501e6c3956206efc9f3c6 (diff)
downloadarmnn-22107e251af9d0b589ea8c47c53c2a6095333272.tar.gz
Add a build option to enable the OpenMP scheduler in ACL.
Signed-off-by: Colm Donelan <colm.donelan@arm.com> Change-Id: I75ee45444cd2f7b895e564e78c29fe67c1a8a4fc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f6a84dd86..660b7555ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -528,6 +528,10 @@ install(DIRECTORY profiling/common/include/ DESTINATION ${CMAKE_INSTALL_INCLUDED
install(DIRECTORY profiling/client/include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/armnn/profiling/client/include)
if(ARMCOMPUTENEON OR ARMCOMPUTECL OR ARMCOMPUTEGPUFSA)
+ if (BUILD_ACL_OPENMP)
+ target_link_libraries(armnn PUBLIC -fopenmp -static-openmp )
+ target_compile_options(armnn PUBLIC -fopenmp)
+ endif()
target_link_libraries(armnn PUBLIC ${ARMCOMPUTE_LIBRARIES})
endif()