aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2023-09-01 14:56:05 +0100
committerFrancis Murtagh <francis.murtagh@arm.com>2023-09-06 12:29:00 +0000
commit0bcd4dac5ed86b2750809295b248d48d6702d922 (patch)
tree7edf3907cba0d03d375e951d7ea7b5f0996fca19 /CMakeLists.txt
parent521ef9648114750d6d88b0f7e2bf6dd88d6ac77a (diff)
downloadarmnn-0bcd4dac5ed86b2750809295b248d48d6702d922.tar.gz
bugfix: install missing profiling headers
Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Change-Id: I996be4822831fc2106d0c8274af24d5359f8c118
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85ad318fc0..bcfb8cf6d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -519,6 +519,9 @@ if(BUILD_ONNX_PARSER)
endif()
install(DIRECTORY include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+# Also install profiling headers used in armnn
+install(DIRECTORY profiling/common/include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/armnn/profiling/common/include)
+install(DIRECTORY profiling/client/include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/armnn/profiling/client/include)
if(ARMCOMPUTENEON OR ARMCOMPUTECL)
target_link_libraries(armnn PUBLIC ${ARMCOMPUTE_LIBRARIES})