aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 603e19b..f2a121d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,11 +46,11 @@ if(BUILD_KERNEL)
add_subdirectory(kernel)
endif()
-if (BUILD_MAILBOX)
+if(BUILD_MAILBOX)
add_subdirectory(mailbox)
endif()
-if (BUILD_REMOTEPROC)
+if(BUILD_REMOTEPROC)
add_subdirectory(remoteproc)
endif()
@@ -59,3 +59,8 @@ add_subdirectory(driver_library)
# Build utils
add_subdirectory(utils)
+
+# Build tests
+if(ETHOSU_TARGET_NPU_CONFIG)
+ add_subdirectory(tests)
+endif()