aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavide Grohmann <davide.grohmann@arm.com>2022-06-16 17:42:58 +0200
committerDavide Grohmann <davide.grohmann@arm.com>2022-08-29 09:52:15 +0200
commitf03642331f1028bdeba1c24bc5d9bd65b42c7603 (patch)
treed299be4d2f9a3b5292b141d531c1a3824b7424ce /CMakeLists.txt
parent43e7dc41eb7f0701951ac84d82f877be37338d41 (diff)
downloadethos-u-linux-driver-stack-f03642331f1028bdeba1c24bc5d9bd65b42c7603.tar.gz
Add linux_driver_stack tests
Change-Id: I303f1424eb46576847312672f7ed5ac03c05aee1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 603e19b..f2a121d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,11 +46,11 @@ if(BUILD_KERNEL)
add_subdirectory(kernel)
endif()
-if (BUILD_MAILBOX)
+if(BUILD_MAILBOX)
add_subdirectory(mailbox)
endif()
-if (BUILD_REMOTEPROC)
+if(BUILD_REMOTEPROC)
add_subdirectory(remoteproc)
endif()
@@ -59,3 +59,8 @@ add_subdirectory(driver_library)
# Build utils
add_subdirectory(utils)
+
+# Build tests
+if(ETHOSU_TARGET_NPU_CONFIG)
+ add_subdirectory(tests)
+endif()