aboutsummaryrefslogtreecommitdiff
path: root/applications/inference_process/CMakeLists.txt
diff options
context:
space:
mode:
authorLedion Daja <ledion.daja@arm.com>2022-11-21 09:23:50 +0100
committerLedion Daja <ledion.daja@arm.com>2022-11-30 14:07:22 +0100
commita7d025a89dff1d532add998392e2dba6ec7129a4 (patch)
tree06b76e6500e8e46d33b73356593a4491219b8107 /applications/inference_process/CMakeLists.txt
parent3227fbddb304683e74af7a485455067bdea40fb8 (diff)
downloadethos-u-core-software-a7d025a89dff1d532add998392e2dba6ec7129a4.tar.gz
Extend inference_process library to use MicroMutableOpResolver
Added compilation flag to allow the inference_process library to use a MicroMutableOpResolver as an alternative to AllOpsResolver. This allows to only make use of the needed operators instead of the complete list of operators, reducing thus the memory footprint of the application. Change-Id: If1d6751b12e8aa301bb466e3ffae92406200eab4
Diffstat (limited to 'applications/inference_process/CMakeLists.txt')
-rw-r--r--applications/inference_process/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/applications/inference_process/CMakeLists.txt b/applications/inference_process/CMakeLists.txt
index 47fae19..4142f11 100644
--- a/applications/inference_process/CMakeLists.txt
+++ b/applications/inference_process/CMakeLists.txt
@@ -37,3 +37,7 @@ if (TARGET ethosu_log)
endif()
target_sources(inference_process PRIVATE src/inference_process.cpp)
+
+if (DEFINED INFERENCE_PROCESS_OPS_RESOLVER)
+ target_compile_definitions(inference_process PRIVATE INFERENCE_PROCESS_OPS_RESOLVER=${INFERENCE_PROCESS_OPS_RESOLVER})
+endif() \ No newline at end of file