aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPer Åstrand <per.astrand@arm.com>2021-01-28 11:13:12 +0100
committerPer Åstrand <per.astrand@arm.com>2021-02-03 13:55:13 +0100
commit83e49967d1c4eeff21025ea0bd449c938c91c5f8 (patch)
tree8e939fb8deb2d6122e2921d20a7318af6f86fdda /CMakeLists.txt
parent3c60f14d2d5074aa25df00e85760e105e3d620bf (diff)
downloadethos-u-core-software-83e49967d1c4eeff21025ea0bd449c938c91c5f8.tar.gz
Split cmsis_startup into _startup and _system21.02-rc1
In order to get better control of the cmsis startup build for secure and nonsecure worlds, the cmsis_startup OBJECT library is split up into two INTERFACE libraries that can be configured and built per executable. Change-Id: I21b6f6af75f9c23e920525ce6c23677f0607745c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcb9605..9d20c14 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,15 +38,6 @@ set_property(CACHE CORE_SOFTWARE_ACCELERATOR PROPERTY STRINGS CPU CMSIS-NN NPU)
set(CORE_SOFTWARE_RTOS "None" CACHE STRING "Select RTOS to include. (None, MbedOS, FreeRTOS, Zephyr)")
string(TOLOWER ${CORE_SOFTWARE_RTOS} CORE_SOFTWARE_RTOS_LOWER)
-# Set trustzone options
-set(TRUSTZONE_BUILD OFF CACHE BOOL "Enable TrustZone build")
-if (TRUSTZONE_BUILD)
- set(TRUSTZONE_SIDE "secure" CACHE STRING "Select secure or nonsecure")
- set_property(CACHE TRUSTZONE_SIDE PROPERTY STRINGS secure nonsecure)
- set(TRUSTZONE_PARTITION_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}" CACHE
- FILEPATH "Path to CMSIS partion header for device")
-endif()
-
#
# Build
#