aboutsummaryrefslogtreecommitdiff
path: root/profiling/common/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'profiling/common/src/CMakeLists.txt')
-rw-r--r--profiling/common/src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/profiling/common/src/CMakeLists.txt b/profiling/common/src/CMakeLists.txt
index 9505fb8869..3a27a53f8e 100644
--- a/profiling/common/src/CMakeLists.txt
+++ b/profiling/common/src/CMakeLists.txt
@@ -27,4 +27,11 @@ if(BUILD_TIMELINE_DECODER)
# to simplify the build. No extra .so file to deploy to boards etc.
add_library_ex(pipeCommon STATIC ${pipeCommon_sources})
+ # install the target
+ install(
+ TARGETS pipeCommon
+ EXPORT armnn-targets
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
endif()