aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48405327c2..c935e6b52d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -541,10 +541,6 @@ list(APPEND armnn_sources
src/profiling/backends/BackendProfiling.cpp
src/profiling/backends/BackendProfiling.hpp
third-party/cxxopts/cxxopts.hpp
- third-party/fmt/core.h
- third-party/fmt/format.h
- third-party/fmt/format-inl.h
- third-party/fmt/src/format.cc
third-party/ghc/filesystem.hpp
third-party/half/half.hpp
)
@@ -587,6 +583,10 @@ if ("${CMAKE_SYSTEM_NAME}" STREQUAL Windows)
target_link_libraries(armnn Ws2_32.lib)
endif()
+# Link fmt third-party library
+add_subdirectory(third-party/fmt)
+target_link_libraries(armnn fmt)
+
if(BUILD_CAFFE_PARSER)
install(TARGETS armnnCaffeParser
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}