aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2020-09-25 08:36:44 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2020-09-29 21:46:41 +0000
commitba3ef18cb6117c49fcdbf177dce5991d6d679cbc (patch)
treecede43ef02deb3271b0da7172b410d29052999b6 /CMakeLists.txt
parent64f787515e8da3cfec089b62e265c4a90543e2f2 (diff)
downloadarmnn-ba3ef18cb6117c49fcdbf177dce5991d6d679cbc.tar.gz
IVGCVSW-5295 Change fmt to be a header-only interface library
* Fix non-virtual-dtor warnings in fmt * Fix wrong fmt include in TfParser * Make fmt work in nn-driver * Make fmt a header-only interface library * Link fmt where necessary Signed-off-by: Jan Eilers <jan.eilers@arm.com> Change-Id: I9db7cd9a133a81262cbf79f04fb419ab97b88ea8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48405327c2..c935e6b52d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -541,10 +541,6 @@ list(APPEND armnn_sources
src/profiling/backends/BackendProfiling.cpp
src/profiling/backends/BackendProfiling.hpp
third-party/cxxopts/cxxopts.hpp
- third-party/fmt/core.h
- third-party/fmt/format.h
- third-party/fmt/format-inl.h
- third-party/fmt/src/format.cc
third-party/ghc/filesystem.hpp
third-party/half/half.hpp
)
@@ -587,6 +583,10 @@ if ("${CMAKE_SYSTEM_NAME}" STREQUAL Windows)
target_link_libraries(armnn Ws2_32.lib)
endif()
+# Link fmt third-party library
+add_subdirectory(third-party/fmt)
+target_link_libraries(armnn fmt)
+
if(BUILD_CAFFE_PARSER)
install(TARGETS armnnCaffeParser
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}