aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f6a84dd86..660b7555ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -528,6 +528,10 @@ install(DIRECTORY profiling/common/include/ DESTINATION ${CMAKE_INSTALL_INCLUDED
install(DIRECTORY profiling/client/include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/armnn/profiling/client/include)
if(ARMCOMPUTENEON OR ARMCOMPUTECL OR ARMCOMPUTEGPUFSA)
+ if (BUILD_ACL_OPENMP)
+ target_link_libraries(armnn PUBLIC -fopenmp -static-openmp )
+ target_compile_options(armnn PUBLIC -fopenmp)
+ endif()
target_link_libraries(armnn PUBLIC ${ARMCOMPUTE_LIBRARIES})
endif()