aboutsummaryrefslogtreecommitdiff
path: root/third-party/fmt/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2020-09-25 08:36:44 +0100
committerTeresaARM <teresa.charlinreyes@arm.com>2020-09-29 21:46:41 +0000
commitba3ef18cb6117c49fcdbf177dce5991d6d679cbc (patch)
treecede43ef02deb3271b0da7172b410d29052999b6 /third-party/fmt/CMakeLists.txt
parent64f787515e8da3cfec089b62e265c4a90543e2f2 (diff)
downloadarmnn-ba3ef18cb6117c49fcdbf177dce5991d6d679cbc.tar.gz
IVGCVSW-5295 Change fmt to be a header-only interface library
* Fix non-virtual-dtor warnings in fmt * Fix wrong fmt include in TfParser * Make fmt work in nn-driver * Make fmt a header-only interface library * Link fmt where necessary Signed-off-by: Jan Eilers <jan.eilers@arm.com> Change-Id: I9db7cd9a133a81262cbf79f04fb419ab97b88ea8
Diffstat (limited to 'third-party/fmt/CMakeLists.txt')
-rw-r--r--third-party/fmt/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/third-party/fmt/CMakeLists.txt b/third-party/fmt/CMakeLists.txt
new file mode 100644
index 0000000000..496ae1fbc6
--- /dev/null
+++ b/third-party/fmt/CMakeLists.txt
@@ -0,0 +1,19 @@
+#
+# Copyright © 2020 Arm Ltd. All rights reserved.
+# SPDX-License-Identifier: MIT
+#
+
+add_library(fmt INTERFACE)
+
+target_compile_definitions(fmt INTERFACE FMT_HEADER_ONLY=1)
+
+target_include_directories(fmt SYSTEM INTERFACE
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>)
+
+install(
+ TARGETS fmt
+ EXPORT armnn-targets
+ LIBRARY DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+) \ No newline at end of file