aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Flynn <jim.flynn@arm.com>2020-11-12 15:48:34 +0000
committerVincent ABRIOU <vincent.abriou@st.com>2021-02-25 16:38:04 +0100
commit27a9bd93bd0f02c8ad866ae0fb70f1c4bb67ef0c (patch)
tree26c5600b68191c9cdb50c4efa312a1c53dd8a6ae /tests/CMakeLists.txt
parent29b49cf1771620233f9c16dfa0214e6d8a64c4d7 (diff)
downloadarmnn-27a9bd93bd0f02c8ad866ae0fb70f1c4bb67ef0c.tar.gz
This application allow to benchmark tflite models by providing average inference time.
Usage: armnn_tfl_benchmark -m <model .tflite> -m --model_file <.tflite file path>: .tflite model to be executed -b --backend <device>: preferred backend device to run layers on by default. Possible choices: CpuAcc, CpuRef -l --loops <int>: provide the number of time the inference will be executed (by default nb_loops=1) Signed-off-by: Vincent ABRIOU <vincent.abriou@st.com> Signed-off-by: Jim Flynn <jim.flynn@arm.com> Change-Id: Ia26fafd4f382f0ad03856436dcae6e71b5abbd26
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index edea34dfee..135f6497be 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -137,6 +137,10 @@ if (BUILD_TF_LITE_PARSER)
addDllCopyCommands(${testName})
endmacro()
+ set(TfLiteBenchmark-Armnn_sources
+ TfLiteBenchmark-Armnn/TfLiteBenchmark-Armnn.cpp)
+ TfLiteParserTest(TfLiteBenchmark-Armnn "${TfLiteBenchmark-Armnn_sources}")
+
set(TfLiteMobilenetQuantized-Armnn_sources
TfLiteMobilenetQuantized-Armnn/TfLiteMobilenetQuantized-Armnn.cpp
ImagePreprocessor.hpp