aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2023-03-16 17:01:56 +0000
committerFrancis Murtagh <francis.murtagh@arm.com>2023-03-31 13:44:19 +0100
commitc4fb0dd4145e05123c546458ba5d281abfcc2b28 (patch)
treef4c6aebaaf4055ff1109a8e963c559aa7ba69945 /delegate/CMakeLists.txt
parent6d4e761f12b0ec34294bae1bfafacd8f468e7e0e (diff)
downloadarmnn-c4fb0dd4145e05123c546458ba5d281abfcc2b28.tar.gz
IVGCVSW-7556 Introduce Opaque Delegate API
* Also added cmake for the new layers to reduce merge conflicts. Signed-off-by: Francis Murtagh <francis.murtagh@arm.com> Change-Id: Ieb59aa2b7e2a18c57c9357b8d5b5cd63d8211c85
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index f6a5e512fa..d35fd4e7b6 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -233,7 +233,7 @@ if(BUILD_UNIT_TESTS)
else()
endif()
- if (BUILD_CLASSIC_DELEGATE) # For Opaque Delegate Unit Tests add OR BUILD_ARMNN_TFLITE_OPAQUE_DELEGATE here
+ if (BUILD_CLASSIC_DELEGATE OR BUILD_OPAQUE_DELEGATE)
add_executable(DelegateUnitTests ${armnnDelegate_unittest_sources})
target_include_directories(DelegateUnitTests SYSTEM PRIVATE "${TF_LITE_SCHEMA_INCLUDE_PATH}")
@@ -241,7 +241,14 @@ if(BUILD_UNIT_TESTS)
# Add half library from armnn third-party libraries
target_link_libraries(DelegateUnitTests PRIVATE thirdparty_headers)
- target_link_libraries(DelegateUnitTests PRIVATE armnnDelegate)
+ if (BUILD_CLASSIC_DELEGATE)
+ target_link_libraries(DelegateUnitTests PRIVATE armnnDelegate)
+ target_include_directories(DelegateUnitTests PUBLIC ${PROJECT_SOURCE_DIR})
+ endif()
+ if (BUILD_OPAQUE_DELEGATE)
+ target_link_libraries(DelegateUnitTests PRIVATE armnnOpaqueDelegate)
+ target_include_directories(DelegateUnitTests PUBLIC ${PROJECT_SOURCE_DIR})
+ endif()
target_link_libraries(DelegateUnitTests PRIVATE Armnn::armnnUtils)
target_link_libraries(DelegateUnitTests PRIVATE profiling_library_headers)