aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Eilers <jan.eilers@arm.com>2021-12-08 10:05:47 +0000
committerKeith Davis <keith.davis@arm.com>2022-06-29 10:04:20 +0100
commita96489a2fd459bd3d73297fa5fdaef5d13a57a4e (patch)
tree2299402be2854c1bd508f57a35edc5c9059961f6 /delegate/CMakeLists.txt
parent764ac655bd301ffc8cde4c912e67499954f9ef8f (diff)
downloadarmnn-a96489a2fd459bd3d73297fa5fdaef5d13a57a4e.tar.gz
Add jni interface for the ArmNN Delegate
* adds a version script to hide away all symbols that are not required to use the interface * the main purpose of the jni interface is to enable the delegate to be used in android apps * Add static building to patch - see patch 7 for JNI patch only Signed-off-by: Jan Eilers <jan.eilers@arm.com> Signed-off-by: Keith Davis <keith.davis@arm.com> Change-Id: I9bb2d698b5fdb0d1b30cf79e6f19746310cd61b2
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 523214bb90..01dde4ebce 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -54,7 +54,7 @@ list(APPEND armnnDelegate_sources
src/Unpack.hpp
src/Transpose.hpp)
-add_library(armnnDelegate SHARED ${armnnDelegate_sources})
+add_library(armnnDelegate ${armnnDelegate_sources})
target_include_directories(armnnDelegate
PUBLIC
@@ -254,6 +254,12 @@ if(BUILD_UNIT_TESTS)
endif()
+option(BUILD_DELEGATE_JNI_INTERFACE "Builds a library to allow accessing the Arm NN delegate from Java code.
+ This is an experimental feature." Off)
+if(BUILD_DELEGATE_JNI_INTERFACE)
+ add_subdirectory(armnnDelegateJNI)
+endif()
+
####################################################
## Export targets
set(armnn_delegate_export_targets)