aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2023-05-03 13:53:02 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2023-05-04 14:14:09 +0000
commit3504e425ac99467c80919768c4a1361c44b30353 (patch)
tree1bef47611d03d61d5ed9083733d0e5654dec3ad8 /delegate/CMakeLists.txt
parentc833cef6240abb941725a667042b84b936f1e86f (diff)
downloadarmnn-3504e425ac99467c80919768c4a1361c44b30353.tar.gz
IVGCVSW-7605 IVGCVSW-7604 Implement Squeeze and ExpandDims operators for Classic and Opaque Delegate
* Implemented unsupported operators in Classic Delegate. * Added unit tests. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ib39eeea53c114b15943e8dc2e796ce64c40cb3a5
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index 003dffa807..ef049133ca 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -150,6 +150,7 @@ if(BUILD_UNIT_TESTS)
test/ElementwiseBinaryTestHelper.hpp
test/ElementwiseUnaryTest.cpp
test/ElementwiseUnaryTestHelper.hpp
+ test/ExpandDimsTest.cpp
test/FillTest.cpp
test/FillTestHelper.hpp
test/FullyConnectedTest.cpp
@@ -193,6 +194,7 @@ if(BUILD_UNIT_TESTS)
test/ShapeTestHelper.hpp
test/SliceTest.cpp
test/SliceTestHelper.hpp
+ test/SqueezeTest.cpp
test/StridedSliceTest.cpp
test/StridedSliceTestHelper.hpp
test/SplitTest.cpp
@@ -280,6 +282,7 @@ if(BUILD_UNIT_TESTS)
test/DepthwiseConvolution2dTest.cpp
test/ElementwiseUnaryTestHelper.hpp
test/ElementwiseUnaryTest.cpp
+ test/ExpandDimsTest.cpp
test/FullyConnectedTest.cpp
test/FullyConnectedTestHelper.hpp
test/GatherTest.cpp
@@ -319,6 +322,7 @@ if(BUILD_UNIT_TESTS)
test/SoftmaxTestHelper.hpp
test/SpaceDepthTest.cpp
test/SpaceDepthTestHelper.hpp
+ test/SqueezeTest.cpp
test/StridedSliceTest.cpp
test/StridedSliceTestHelper.hpp
test/TestUtils.hpp