aboutsummaryrefslogtreecommitdiff
path: root/delegate/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Sloyan <matthew.sloyan@arm.com>2023-04-24 12:53:04 +0100
committerMatthew Sloyan <matthew.sloyan@arm.com>2023-04-24 18:03:44 +0100
commit080ffd84eccb4b849c192155c0ba39431d53c894 (patch)
treeb6ef09a3c5139ff900f627fc45d665c7e78401b9 /delegate/CMakeLists.txt
parent1ffbaac882792f166357ecf388667e8405c69966 (diff)
downloadarmnn-080ffd84eccb4b849c192155c0ba39431d53c894.tar.gz
IVGCVSW-7584 Implement Conv2d and DepthwiseConv2d operators for Opaque Delegate
* Added VisitConvolution2d and VisitDepthwiseConv2d functions to Convolution2d.hpp. * Enabled Convolution2d and DepthwiseConv2d tests. * Moved TransposeConvolution2d tests to separate file. * Added Opaque Delegate shared functions. Signed-off-by: Matthew Sloyan <matthew.sloyan@arm.com> Change-Id: Ica10c9469fc830f512edad1ad79884f90ae511d0
Diffstat (limited to 'delegate/CMakeLists.txt')
-rw-r--r--delegate/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/delegate/CMakeLists.txt b/delegate/CMakeLists.txt
index f8b6ea52d1..b81feb6b1e 100644
--- a/delegate/CMakeLists.txt
+++ b/delegate/CMakeLists.txt
@@ -198,6 +198,7 @@ if(BUILD_UNIT_TESTS)
test/SplitTestHelper.hpp
test/TestUtils.hpp
test/TestUtils.cpp
+ test/TransposeConvolution2dTest.cpp
test/TransposeTest.cpp
test/TransposeTestHelper.hpp
test/UnidirectionalSequenceLstmTest.cpp
@@ -258,10 +259,13 @@ if(BUILD_UNIT_TESTS)
common/src/test/DelegateTestInterpreterUtils.hpp
opaque/src/test/ArmnnOpaqueDelegateTest.cpp
opaque/src/test/DelegateTestInterpreter.cpp
- test/TestUtils.hpp
- test/TestUtils.cpp
test/CastTest.cpp
- test/CastTestHelper.hpp)
+ test/CastTestHelper.hpp
+ test/Convolution2dTest.cpp
+ test/ConvolutionTestHelper.hpp
+ test/DepthwiseConvolution2dTest.cpp
+ test/TestUtils.hpp
+ test/TestUtils.cpp)
# Until all operators are supported, we have to add tests one by one above to opaqueDelegate_unittest_sources.
# After we add can add commonDelegate_unittest_sources to the add_executable below.