aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNikhil Raj <nikhil.raj@arm.com>2020-10-09 14:52:25 +0100
committerJim Flynn <jim.flynn@arm.com>2020-10-27 10:09:22 +0000
commite51815323bbc0b07a329af9fb22fc4944132af45 (patch)
tree7a36fcda799c672b38366eb2282be12cfca4a709 /CMakeLists.txt
parent0f74e92354018cece0f55d37d583288699a72b84 (diff)
downloadarmnn-e51815323bbc0b07a329af9fb22fc4944132af45.tar.gz
IVGCVSW-5077 Ensure ArmNN builds successfully with latest protobuf
* Use the single parameter version of SetTotalBytesLimit() * Update CMakeLists to turn off deprecated declarartions Signed-off-by: Nikhil Raj <nikhil.raj@arm.com> Change-Id: I2d360966743986872cfef40c2ab1a3505fc5d99a
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06a9bb837d..99e989b08c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,7 +145,7 @@ if(BUILD_TF_PARSER)
)
# The generated tensorflow protobuf .cc files are not warning clean and we can't fix them.
if(COMPILER_IS_GNU_LIKE)
- set_source_files_properties(${TF_PROTOBUFS} PROPERTIES COMPILE_FLAGS "-Wno-unused-variable -Wno-unused-parameter -Wno-conversion -Wno-sign-conversion")
+ set_source_files_properties(${TF_PROTOBUFS} PROPERTIES COMPILE_FLAGS "-Wno-unused-variable -Wno-unused-parameter -Wno-conversion -Wno-sign-conversion -Wno-error=deprecated-declarations")
endif()
add_library_ex(armnnTfParser SHARED ${armnn_tf_parser_sources})