aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRob Hughes <robert.hughes@arm.com>2020-05-20 13:11:37 +0100
committerRob Hughes <robert.hughes@arm.com>2020-06-02 14:55:00 +0000
commitbc873d2dac4666a86e4844985199dfd90e67be5b (patch)
tree478688dc9a28b497a13ce7b65ef786d1d8b4547b /CMakeLists.txt
parentbb46dde88befe14583eaac83f65775a7543d4586 (diff)
downloadarmnn-bc873d2dac4666a86e4844985199dfd90e67be5b.tar.gz
Tidy up uses of Windows.h by adding WindowsWrapper.hpp
This header brings in the Win32 API header, with some small modifications applied to prevent clashes with our code. This means those modifications don't need to be made in each place that we bring in Windows.h Change-Id: Ie817c7a167eccbe1ac6a49d3fc940eef8b2f534d Signed-off-by: Robert Hughes <robert.hughes@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88e813a357..8f8060a10b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,7 @@ list(APPEND armnnUtils_sources
src/armnnUtils/TensorIOUtils.hpp
src/armnnUtils/TensorUtils.cpp
src/armnnUtils/Transpose.cpp
+ src/armnnUtils/WindowsWrapper.hpp
)
add_library_ex(armnnUtils STATIC ${armnnUtils_sources})
@@ -255,6 +256,7 @@ list(APPEND armnn_sources
profiling/common/include/ProfilingException.hpp
profiling/common/include/SocketConnectionException.hpp
profiling/common/include/Constants.hpp
+ profiling/common/include/NetworkSockets.hpp
profiling/common/src/NetworkSockets.cpp
src/armnn/layers/LayerCloneBase.hpp
src/armnn/layers/LayerWithParameters.hpp
@@ -1076,6 +1078,7 @@ if(BUILD_GATORD_MOCK)
target_include_directories(GatordMock PRIVATE profiling/common/include
profiling/server/src/basePipeServer
+ src/armnnUtils
src/profiling
src/timelineDecoder)