aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Murtagh <francis.murtagh@arm.com>2022-07-22 10:23:41 +0100
committerNikhil Raj <nikhil.raj@arm.com>2022-07-27 15:58:02 +0100
commit4073e147982df3022ea97cb85179c8c7a695a17a (patch)
tree657123d837744e982cc87c4ef024a5fbb60a0c8a /CMakeLists.txt
parent1e276f38e67af7505a25010eee579034ee83d12b (diff)
downloadarmnn-4073e147982df3022ea97cb85179c8c7a695a17a.tar.gz
IVGCVSW-6978: RedirectMembersToConstantInputs does not work with Fp32NetworkToBf16Converter
* Fuse FP32ToBF16Layers with Constant Layer so Conv2d/FullyConnected can have their weights redirected. * If BF16 Unsupported in Conv2d || FullyConnected revert fused Constant Layer to FP32 Change-Id: If523c708a822659d64597d9ae39cca1c2f84b76f Signed-off-by: Francis Murtagh <francis.murtagh@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41db8661d3..f0eb81cc6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -547,6 +547,7 @@ if(BUILD_UNIT_TESTS)
src/armnn/test/optimizations/Fp32NetworkToFp16ConverterTests.cpp
src/armnn/test/optimizations/FuseActivationTests.cpp
src/armnn/test/optimizations/FuseBatchNormTests.cpp
+ src/armnn/test/optimizations/FuseConvertF32BF16IntoConstLayerTests.cpp
src/armnn/test/optimizations/InsertDebugLayerTests.cpp
src/armnn/test/optimizations/MovePermuteUpTests.cpp
src/armnn/test/optimizations/MoveTransposeUpTests.cpp