aboutsummaryrefslogtreecommitdiff
path: root/thirdparty/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'thirdparty/CMakeLists.txt')
-rw-r--r--thirdparty/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
index a85af3c..abcc52c 100644
--- a/thirdparty/CMakeLists.txt
+++ b/thirdparty/CMakeLists.txt
@@ -1,8 +1,17 @@
cmake_minimum_required (VERSION 3.4)
+# fetch 3rd party libraries
+include(FetchContent)
+FetchContent_Declare(
+ cxxopts
+ URL https://github.com/jarro2783/cxxopts/archive/v2.2.1.tar.gz
+ URL_MD5 6e70da4fc17a09f32612443f1866042e
+)
+
set(CMAKE_INSTALL_PREFIX "./thirdparty" CACHE PATH "..." FORCE)
project(thirdparty LANGUAGES CXX)
+add_subdirectory(cxxopts)
add_subdirectory(serialization_lib EXCLUDE_FROM_ALL)
add_subdirectory(json EXCLUDE_FROM_ALL)