summaryrefslogtreecommitdiff
path: root/source/hal/cmsis_device/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/hal/cmsis_device/CMakeLists.txt')
-rw-r--r--source/hal/cmsis_device/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/source/hal/cmsis_device/CMakeLists.txt b/source/hal/cmsis_device/CMakeLists.txt
index 4e5ce72..05c6005 100644
--- a/source/hal/cmsis_device/CMakeLists.txt
+++ b/source/hal/cmsis_device/CMakeLists.txt
@@ -49,6 +49,10 @@ target_include_directories(${CMSIS_DEVICE_TARGET}
## Sources
target_sources(${CMSIS_DEVICE_TARGET}
+ PUBLIC
+ source/handlers.c)
+
+target_sources(${CMSIS_DEVICE_TARGET}
PRIVATE
${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Source/system_${ARM_CPU}.c
${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Source/startup_${ARM_CPU}.c)