summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-02-23 14:40:45 +0000
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-02-23 17:34:33 +0000
commita1256e3881d1ec3e77b341dbb0c5c5dbf7ab3247 (patch)
treee0e23355a7bdbf6a62360e5391c2a3bd0763f0e3 /CMakeLists.txt
parentfb246a834d4cb9392463f499158ca44f7e443492 (diff)
downloadml-embedded-evaluation-kit-a1256e3881d1ec3e77b341dbb0c5c5dbf7ab3247.tar.gz
MLECO-2948: Minor refactoring for platform modules.
Reducing dependency on cmsis-device sources as these will be removed under MLECO-2944. Also, starting to refactor to allow HAL to drop NPU and TA init routines - this will happen in future CRs. Added platform driver for native, and subsequent patches will attempt to get rid of the HAL "profile" specific sources and allow platform stub implementations at a level below HAL. This will allow platforms drivers to only override the range of functions that they actually want to implement and will fall back on stubs for the rest. In this CR only "utils" have been removed. Change-Id: I09b4a28e20847a07a956c818c6f47c74aab89063
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14ec1aa..bbd7756 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -236,4 +236,4 @@ foreach(use_case ${USE_CASES})
endforeach()
-print_useroptions() \ No newline at end of file
+print_useroptions()