summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2022-05-20 14:30:02 +0100
committerKshitij Sisodia <kshitij.sisodia@arm.com>2022-05-23 16:11:45 +0100
commit9c6f9f8afcb003fd72944918d6b6e200d68c0918 (patch)
treeb1237909970ac74232f4ed81a26edc0847204269 /CMakeLists.txt
parent6f6df0934f991b64fef494b86643b3f5074fca0e (diff)
downloadml-embedded-evaluation-kit-9c6f9f8afcb003fd72944918d6b6e200d68c0918.tar.gz
MLECO-3225: Using official support for Arm Cortex-M85 CPU.
* CMake version requirement bumped up to 3.21.0 * CMake 3.22.4 installed in the local Python virtualenv * CPU flags updated in toolchain files. * Using __ARM_FEATURE_DSP instead of potentially defining ARM_MATH_DSP wrongly. * CMake project version bumped up to 22.05.0 Changes also made for MLECO-3107 (pack generation): * TensorFlow Lite Micro CMSIS-pack version updated to 1.22.02. * Change to using __ARM_FEATURE_DSP will also help the generated pack. Partial changes for MLECO-3095: * CMSIS updated to version post 5.9.0 * TensorFlow Lite Micro updated to latest available * Ethos-U driver and core-platform repositories updated to 20.05_rc2 tags. Change-Id: I012c9e65897aed8ce589cff9bfe3a19efc3edeb9 Signed-off-by: Kshitij Sisodia <kshitij.sisodia@arm.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index feb69b6..150c668 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#----------------------------------------------------------------------------
-cmake_minimum_required(VERSION 3.16.3)
+cmake_minimum_required(VERSION 3.21.0)
include(ExternalProject)
# Build in release mode by default
@@ -83,7 +83,7 @@ if(POLICY CMP0123)
endif()
project(arm_ml_embedded_evaluation_kit
- VERSION 22.02.0
+ VERSION 22.05.0
DESCRIPTION "ARM ML Embedded Evaluation Kit"
LANGUAGES C CXX ASM)
@@ -227,7 +227,8 @@ foreach(use_case ${USE_CASES})
arm_math
hal
profiler
- tensorflow-lite-micro)
+ tensorflow-lite-micro
+ common_api)
# If an API exists for this use case, include the projects here and add to
# the library list.