summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNina Drozd <nina.drozd@arm.com>2022-02-10 13:33:20 +0000
committerNina Drozd <nina.drozd@arm.com>2022-02-14 17:01:26 +0000
commit5916952c0fe6167989afa363829fc4e1d053c683 (patch)
treefb9ea988db72f8a6119dbe43c401f592716f50d9 /CMakeLists.txt
parented35a6fea4a1604db81c56fc71f7756822fcf212 (diff)
downloadml-embedded-evaluation-kit-5916952c0fe6167989afa363829fc4e1d053c683.tar.gz
MLECO-2853: update cmake flags for Armclang
* set CMP0123 policy to remove warning * remove parentheses to avoid assert is always true warning Change-Id: Ifcdf089183d750d7b00b345f5c4115c82d897def
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e61e378..7dccd75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,10 @@ assert_defined(USE_CASE_BUILD)
assert_defined(CPU_PROFILE_ENABLED)
assert_defined(CMAKE_TOOLCHAIN_FILE)
+if(POLICY CMP0123)
+ cmake_policy(SET CMP0123 NEW)
+endif()
+
project(arm_ml_embedded_evaluation_kit
VERSION 21.11.1
DESCRIPTION "ARM ML Embedded Evaluation Kit"