summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKshitij Sisodia <kshitij.sisodia@arm.com>2021-10-29 12:29:06 +0100
committerKshitij Sisodia <kshitij.sisodia@arm.com>2021-10-29 17:56:00 +0100
commit3be2623cb0ccf4a86bbf06be09d438767a960ca5 (patch)
tree31fed74e309152f3298f98940ac02b8d41b6e228 /CMakeLists.txt
parent79d4154ee071d0e7ef2d1eecdde149d488bb9d8b (diff)
downloadml-embedded-evaluation-kit-3be2623cb0ccf4a86bbf06be09d438767a960ca5.tar.gz
MLECO-2512: Minor improvement for helper scripts.
Python scripts 'build_default.py' and 'set_up_default_resources.py' now allow building for non-default Ethos-U configurations: H32, H64, H256 and Y512. Change-Id: Iefdbf135410396c4dc0be73462644725d4b47910
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 523bcaa..d18105d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,7 +72,7 @@ USER_OPTION(TARGET_SUBSYSTEM "Specify platform target subsystem: sse-300 or none
sse-300
STRING)
-USER_OPTION(ETHOS_U_NPU_ENABLED "Select if Ethos-U55 is available for the platform and subsystem"
+USER_OPTION(ETHOS_U_NPU_ENABLED "Select if Ethos-U NPU is available for the platform and subsystem"
ON
BOOL)
@@ -166,15 +166,15 @@ endif ()
# If we need NPU libraries:
if (ETHOS_U_NPU_ENABLED)
- message(STATUS "Using ARM Ethos-U55 - adding core-driver and timing-adapter-driver includes and libraries")
+ message(STATUS "Using ARM Ethos-U NPU - adding core-driver and timing-adapter-driver includes and libraries")
USER_OPTION(ETHOS_U_NPU_TIMING_ADAPTER_SRC_PATH
- "Path to Ethos-U55 timing adapter sources"
+ "Path to Ethos-U NPU timing adapter sources"
"${CMAKE_CURRENT_SOURCE_DIR}/dependencies/core-software/drivers/timing_adapter"
PATH
)
USER_OPTION(ETHOS_U_NPU_DRIVER_SRC_PATH
- "Path to Ethos-U55 core driver sources"
+ "Path to Ethos-U NPU core driver sources"
"${CMAKE_CURRENT_SOURCE_DIR}/dependencies/core-driver"
PATH
)