summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorayamas01 <ayaan.masood@arm.com>2021-11-18 14:22:23 +0000
committerAyaan Masood <Ayaan.Masood@arm.com>2021-11-18 16:20:54 +0000
commit15f80701751f09caa023dabea6dec45f3825fa5b (patch)
tree851ee015c06b1435ee43afa3d59725931ae6f698 /CMakeLists.txt
parente7a0393973a1a1c1ed05b1bf1838fe931416890a (diff)
downloadml-embedded-evaluation-kit-15f80701751f09caa023dabea6dec45f3825fa5b.tar.gz
MLECO-2525 Upgrade to C++ 14
-Updated CMake to use C++ 14 -Removed cmsis makefile include from tensorflow.cmake -Documentation update -Added more flags for processor in CMake Change-Id: I1c2b72141e98a5cf8bb09176d7c331da3b05b4c5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d18105d..b747018 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,7 @@ message(STATUS "Build type is set to ${CMAKE_BUILD_TYPE}")
# Set language standards. TensorFlow Lite requires
# std=c++11.
set(CMAKE_C_STANDARD 99)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
# Make the standard a requirement => prevent fallback to previous
# supported standard
@@ -159,8 +159,8 @@ if (${CMAKE_CROSSCOMPILING})
set(CMSIS_HEADERS
${CMSIS_DSP_INC_DIR}
${CMSIS_CORE_INC_DIR}
- ${CMSIS_SRC_PATH}/Device/ARM/ARMCM55/Include
- ${CMSIS_SRC_PATH}/Device/ARM/ARMCM55/Include/Template)
+ ${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Include
+ ${CMSIS_SRC_PATH}/Device/ARM/${ARM_CPU}/Include/Template)
endif ()
# If we need NPU libraries: