aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTim Hall <tim.hall@arm.com>2020-11-09 16:46:37 +0000
committerTim Hall <tim.hall@arm.com>2020-11-11 11:38:41 +0000
commite6ccd87a2f40877cacdd9721a5116a6853dfe573 (patch)
tree8e22dacc02e82df59cb460b68d39e5fd338abf4d /setup.py
parente168b969dc75fc3057413a80fdf0e164ab936910 (diff)
downloadethos-u-vela-e6ccd87a2f40877cacdd9721a5116a6853dfe573.tar.gz
MLBEDSW-3019: Add profiling debug database
- Added mechanism to track input to output graph transforms for debugging the resultant command stream. - Provides base implementation for MLBEDSW-2661 Signed-off-by: Tim Hall <tim.hall@arm.com> Change-Id: I2dfe8a409fbde7ad0282bfab5acb11ba1c8b82d8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 07ab2d13..cc306360 100644
--- a/setup.py
+++ b/setup.py
@@ -56,7 +56,7 @@ setup(
keywords=["ethos-u", "vela compiler", "tflite", "npu"],
packages=find_namespace_packages(include=["ethosu.*"]),
python_requires="~=3.6", # We support only 3.6+
- install_requires=["flatbuffers==1.11.0", "numpy>=1.16.6"],
+ install_requires=["flatbuffers==1.11.0", "numpy>=1.16.6", "lxml>=4.6.1"],
entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
ext_modules=[mlw_module],
setup_requires=["setuptools_scm"],