aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLouis Verhaard <louis.verhaard@arm.com>2021-01-20 17:23:54 +0100
committerLouis Verhaard <louis.verhaard@arm.com>2021-02-12 17:40:21 +0100
commitd70025250fc49997801ea3a6ce83f2fa29a09d78 (patch)
tree07462a32ed30ba9893bb7825e44b9606a400e709 /setup.py
parentad45f792e699fe6abdc381f62690801aa50bd412 (diff)
downloadethos-u-vela-d70025250fc49997801ea3a6ce83f2fa29a09d78.tar.gz
MLBEDSW-3808: Ported search allocator to python2.1.0.rc1
- Straight port of the C++ implementation to python. - Renamed the allocator from "Search" to "HillClimb" Change-Id: I50797d541f326d0264daf79bf7866aef32350a60 Signed-off-by: Louis Verhaard <louis.verhaard@arm.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 1 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index f67d42e7..98dfe525 100644
--- a/setup.py
+++ b/setup.py
@@ -44,12 +44,6 @@ mlw_module = Extension(
["ethosu/mlw_codec/mlw_encode.c", "ethosu/mlw_codec/mlw_decode.c", "ethosu/mlw_codec/mlw_codecmodule.c"],
)
-tensor_allocator_module = Extension(
- "ethosu.tensor_allocator",
- ["ethosu/tensor_allocator/tensor_allocatormodule.cpp", "ethosu/tensor_allocator/search_allocator.cpp"],
- depends=["ethosu/tensor_allocator/search_allocator.h"],
-)
-
setup(
name="ethos-u-vela",
use_scm_version=True,
@@ -66,7 +60,6 @@ setup(
"Operating System :: POSIX :: Linux",
"Operating System :: Microsoft :: Windows",
"Programming Language :: C",
- "Programming Language :: C++ :: C++11",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
@@ -84,6 +77,6 @@ setup(
"lxml>=4.5.1",
],
entry_points={"console_scripts": ["vela = ethosu.vela.vela:main"]},
- ext_modules=[mlw_module, tensor_allocator_module],
+ ext_modules=[mlw_module],
setup_requires=["setuptools_scm"],
)