aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDwight Lidman <dwight.lidman@arm.com>2021-05-12 19:09:28 +0200
committerDwight Lidman <dwight.lidman@arm.com>2021-05-18 13:57:03 +0200
commitbf2eefc35d029f9d9174769716d2479ae00876f3 (patch)
treea9bdf9b75e9b9c01bec315449e30083cd0dd9fc2 /setup.py
parent06329fc1c4c802ed203cb32cc6eda30871577bfb (diff)
downloadethos-u-vela-bf2eefc35d029f9d9174769716d2479ae00876f3.tar.gz
MLBEDSW-4417: Explicitly set packages in setup.py
This commit removes usage of the function find_namespace_packages (which is not available in older versions of setuptools) and instead explicitly states the namespace packages in setup.py. Signed-off-by: Dwight Lidman <dwight.lidman@arm.com> Change-Id: I942f339953d50a7bf5fc3e83c0736813fea58dd2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b2c25ead..18c0bc7f 100644
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,6 @@ import os
import re
from setuptools import Extension
-from setuptools import find_namespace_packages
from setuptools import setup
from setuptools.command.build_ext import build_ext
@@ -83,8 +82,8 @@ setup(
"Topic :: Software Development :: Compilers",
],
keywords=["ethos-u", "vela compiler", "tflite", "npu"],
- packages=find_namespace_packages(include=["ethosu.*"]),
- python_requires="~=3.6", # We only test for 3.6.*
+ packages=["ethosu.vela", "ethosu.mlw_codec"],
+ python_requires="~=3.6", # We support only 3.6+
install_requires=[
"flatbuffers==1.12.0",
"numpy>=1.16.6",