aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRickard Bolin <rickard.bolin@arm.com>2022-04-25 11:07:56 +0000
committertim.hall <tim.hall@arm.com>2022-05-18 14:40:37 +0000
commit1538dce9f07a310587f057aee5fbe25509963879 (patch)
treed26781bb52598301fa07aa5ca8403ff190a6037b /setup.py
parentc1be0873d9e28a21c7873793da896e6dd576292f (diff)
downloadethos-u-vela-1538dce9f07a310587f057aee5fbe25509963879.tar.gz
MLBEDSW-4783: Add config file directory structure
Add directory structure to support third party config files. Config files should now be placed in an appropriately named directory under the config_files directory, but can also be accessed by providing its absolute path to vela --config. Signed-off-by: Rickard Bolin <rickard.bolin@arm.com> Change-Id: I2fcf52e7b2ddd2c4491dc370c85c0b3937d18062
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 244fc4ed..d6e03b1d 100644
--- a/setup.py
+++ b/setup.py
@@ -83,12 +83,14 @@ setup(
],
keywords=["ethos-u", "vela compiler", "tflite", "npu"],
packages=[
+ "ethosu",
"ethosu.vela",
"ethosu.vela.ethos_u55_regs",
"ethosu.vela.tflite",
"ethosu.vela.tosa",
"ethosu.mlw_codec",
],
+ package_data={"ethosu": ["config_files/*/*.ini"]},
python_requires="~=3.7",
install_requires=[
"flatbuffers==1.12.0",