aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavide Grohmann <davide.grohmann@arm.com>2022-04-07 14:50:50 +0200
committerDavide Grohmann <davide.grohmann@arm.com>2022-04-12 12:52:23 +0200
commit80f8ddf050d594ec663b01cb800e9547c9f919d0 (patch)
tree8952b03560639a89a0780335e28abc0ccc83c8be /CMakeLists.txt
parent442fefb74a28307cfcd009723504ea5ac1353430 (diff)
downloadethos-u-linux-driver-stack-80f8ddf050d594ec663b01cb800e9547c9f919d0.tar.gz
Drop tflite and flatbuffer dependencies
There is not real need for the linux_driver_stack to know about tflite and flatbuffers. A better approach is to just pass the buffer to the firmware to be processes, i.e., either parsed or executed. This solves issues when linux_driver_stack and firmware are not in sync with the same library versions. Change-Id: I9b2a12e69f37f61b1ac594433a15883fb1c67b9c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e447afb..603e19b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2020-2021 Arm Limited. All rights reserved.
+# Copyright (c) 2020-2022 Arm Limited. All rights reserved.
#
# SPDX-License-Identifier: Apache-2.0
#
@@ -54,16 +54,6 @@ if (BUILD_REMOTEPROC)
add_subdirectory(remoteproc)
endif()
-# Build flatbuffers
-unset(PROJECT_VERSION)
-unset(PROJECT_VERSION_MAJOR)
-unset(PROJECT_VERSION_MINOR)
-option(FLATBUFFERS_BUILD_TESTS OFF)
-option(FLATBUFFERS_INSTALL OFF)
-option(FLATBUFFERS_BUILD_FLATC OFF)
-option(FLATBUFFERS_BUILD_FLATHASH OFF)
-add_subdirectory(flatbuffers)
-
# Build driver library
add_subdirectory(driver_library)