aboutsummaryrefslogtreecommitdiff
path: root/lib/layer_by_layer_profiler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/layer_by_layer_profiler/CMakeLists.txt')
-rw-r--r--lib/layer_by_layer_profiler/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/lib/layer_by_layer_profiler/CMakeLists.txt b/lib/layer_by_layer_profiler/CMakeLists.txt
index 7a16da2..1e3d012 100644
--- a/lib/layer_by_layer_profiler/CMakeLists.txt
+++ b/lib/layer_by_layer_profiler/CMakeLists.txt
@@ -21,6 +21,17 @@ if (NOT TARGET ethosu_core_driver)
endif()
add_library(layer_by_layer_profiler INTERFACE)
-target_link_libraries(layer_by_layer_profiler INTERFACE ethosu_core_driver tflu event_recorder ethosu_log)
-target_include_directories(layer_by_layer_profiler INTERFACE include)
-target_sources(layer_by_layer_profiler INTERFACE src/layer_by_layer_profiler.cpp)
+
+target_link_libraries(layer_by_layer_profiler INTERFACE
+ ethosu_core_driver
+ tflu event_recorder
+ ethosu_log)
+
+target_include_directories(layer_by_layer_profiler INTERFACE
+ include)
+
+target_sources(layer_by_layer_profiler INTERFACE
+ src/layer_by_layer_profiler.cpp)
+
+target_compile_definitions(layer_by_layer_profiler INTERFACE
+ LAYER_BY_LAYER_PROFILER)